Preliminares




descargar 68.03 Kb.
títuloPreliminares
página7/7
fecha de publicación24.02.2016
tamaño68.03 Kb.
tipoBibliografía
b.se-todo.com > Documentos > Bibliografía
1   2   3   4   5   6   7

Guía de referencia

  1. Abrir imágenes LCT


Dado que ImageJ fue diseñado con una arquitectura abierta, se pudo modificar el código fuente de distintos archivos para que detectasen este nuevo formato LCT.

Para proceder a su apertura, tan solo debemos ir a la barra de menú y seleccionar “File” > “Open”, y seleccionar el archivo .lct que deseemos abrir (tanto comprimidas como sin comprimir).

Al proceder a abrir el archivo, nos aparecerá la siguiente pantalla que se puede visualizar en la figura X.X.



Donde nos permite seleccionar en qué formato deseamos abrir la imagen:

  • Short: Utiliza 16 bits para representar con números enteros cada pixel (enteros situados en el rango 0..65535).

  • Float: Utiliza 32 bits para representar cada pixel, y los valores de la imagen se encontrarán en punto flotante.

  • Byte: Utiliza 8 bits para representar con números enteros cada pixel (enteros situados en el rango 0..255).

Una vez seleccionado el tipo de dato a utilizar, se abrirá la imagen seleccionada, como se puede visualizar en la figura X.X.

Guardar imagen en el formato LCT


Para guardar una imagen en el formato LCT, se debe seleccionar la imagen que se desea guardar (se hace ‘click’ sobre ella, y se iluminará su barra de estado) y luego se accede a la barra de menú “File” > “Save As..” > “Save as LCT…”.



Posteriormente, nos mostrará una pantalla indicando en qué lugar se desea almacenar la imagen y el nombre del archivo (no hace falta indicar la extensión del archivo, ya que automáticamente añade la extensión .lct en caso de no haberla indicado en el nombre). Y acto seguido se nos abrirá una pantalla indicando si se desea almacenarla de manera “Comprimida” o “Normal”.



Tras seleccionar cómo deseamos guardar la imagen, y en caso de que todo haya ido bien, se mostrará una pantalla indicando que se ha guardado el archivo, junto con su ruta completa, tal como se visualiza en la figura X.X.


Plugin Alg_Adaptativo


Este plugin es el que implementa el algoritmo adaptativo. Para ello, seleccionamos la imagen que deseamos ejecutar el algoritmo, y seleccionamos en la barra de menú “Plugins” > “Alg_Adaptativo”. Una vez seleccionado el plugin, se nos abrirá una pantalla indicándonos cuántos vecinos queremos que busque por cada píxel (por defecto 100), tal como se puede apreciar en la figura X.X.



Anexo I. Uso de ImageJ

Conceptos básicos

Ventana


La ventana de ImageJ contiene una barra de menú, de herramientas, una barra de estado y otra de progreso.

Las imágenes pueden ser copiadas en el cortapapeles, editadas, impresas y guardadas.

Barra de herramientas




La barra de herramientas contiene herramientas para hacer selecciones, zoom y desplazamiento de imágenes, y para cambiar el color del dibujo. Al pasar el ratón sobre cada herramienta, aparecerá una breve descripción en la barra de estado.

Las herramientas y menús de la parte derecha son creados usando las macros definidas en el fichero ImageJ/macros/StartupMacros.txt.

Barra de estado


La barra de estado, cuando el cursor está sobre una imagen, muestra las coordenadas del pixel y su valor. Después de ejecutar un filtro, se muestra el tiempo transcurrido y la tasa de procesamiento de píxeles por segundo.

Barra de progreso


http://rsbweb.nih.gov/ij/docs/images/progress.gif

La barra de progreso, localizada a la derecha de la barra de estado, muestra el progreso del tiempo consumido en las operaciones. En caso de que la operación requiera menos de un segundo, esta barra no será mostrada.


Imágenes


ImageJ permite que múltiples imágenes sean mostradas al mismo tiempo. La ventana activa será la que tenga la barra de título resaltada.

ImageJ soporta 8 bits, 16-bit y 32-bit (real) en escala de grises y de 8 bits y 32 bits de imágenes en color.

  • Las imágenes de 8 bits se representan mediante enteros sin firmar en el rango de 0 a 255.

  • Las imágenes de 16 bits usa unsigned enteros (0 a 65.535).

  • Imágenes de 32 bits en escala de grises utilización números de punto flotante.

Las imágenes de 16-bit y 32-bits en escala de grises no se pueden mostrar directamente en los monitores de ordenador, que normalmente sólo puede mostrar 256 tonos de gris. Por lo tanto, los datos se asignan a 8-bits por ventana. La ventana define la gama de grises que muestra: valores por debajo de la ventana son negro, mientras que valores por encima de la ventana son de color blanco. Los valores mínimos y máximos de la ventana se pueden modificar Imagen> Ajustar> Brillo > Contraste.

Stacks (pila)




ImageJ puede mostrar múltiples imágenes en una simple ventana. Estas series de imágenes son denominadas pilas(stacks).

Las imágenes que componen una pila (stacks), son denominados “capas” (slices). Todas las capas de la pila deben tener el mismo tamaño y número de bits. Una barra de desplazamiento permite el movimiento por las distintas capas. Si se realiza un filtro, este filtro será aplicado en todas las capas de la pila.

ImageJ abre múltiples imágenes TIFF como una pila, y salva pilas como mútiples imágenes TIFFs. El comando File>Import>Image Sequence abre una carpeta de imágenes como una pila. Para crear una nueva pila, simplemente elegimos File>New>Image y en el campo “Slices” se introduce un valor mayor a uno. El submenú Image>Stacks contiene comandos para las operaciones comunes de una pila.

Selecciones




Las selecciones son áreas definidas por el usuario o líneas en una imagen. Solo una selección puede ser activada al mismo tiempo. Las selecciones de áreas se crean usando el rectángulo, elipse, polígono y mano alzada. Las áreas pueden ser medidas (Analyze > Measure), filtradas, rellenas (Edit > Fill) o dibujadas (Edit > Draw). Las selecciones de línea se crean utilizando las herramientas de línea, segmento o mano alzada. Usa Edit > Draw para dibjar la línea en el color seleccionado. El grosor de la línea puede ser modificada usando Analyze > Measure.

Las selecciones pueden ser movidas haciendo click en ellas y arrastrándolas. La barra de estado muestra las coordenadas de la esquina superior de la selección, a medida que se mueve. Notar que el cursor cambia su forma cuando está dentro de la selección. Para mover el contenido de una selección rectangular, seleccionamos Edit > Copy, Edit > Paste, y a continuación, hacemos click en la selección y arrastramos. Utilice las teclas de dirección para mover lo seleccionado de píxel en píxel (en cualquier dirección).

El rectángulo y la elipse pueden ser redimensionadas. Seleccionamos la zona a redimensionar, el ancho y alto son mostrados en la barra de estado. Use las teclas de flechas con la tecla ALT para estirar las selecciones un píxel cada vez.

Para eliminar una selección, elegir cualquiera de las herramientas de selección, hacemos click fuera de la selección o seleccionando Edit >Selection > Select None (shift-a). Usa Edit > Selection > Restore Selection para restaurar la selección después de haberla eliminado.

Una selección puede ser transferida de una ventana a otra mediante la activación de la ventana de destino y seleccionando Edit> Selection > Restore Selection. Las selecciones se pueden guardar en el disco utilizando File> Save As > Selection y restaurarlo utilizando File > Open.

File Formats


Si se selecciona File > Open, pueden abrirse imágenes TIFF, GIF, JPEG, PNG, DICOM, BMP, PGM y FITD. También abre tablas de búsqueda (“look up tables”) y selecciones. Además, el submenú Archivo > Importar permite el acceso a los plugins para leer archivos RAW, imágenes en formato ASCII, y para la carga de imágenes a través de la red utilizando una dirección URL. Para importar un archivo RAW, se debe conocer cierta información sobre el diseño, incluyendo el tamaño de la imagen y la compensación a los datos de la imagen. Los archivos pueden guardarse en formato TIFF, GIF, JPEG, PNG, PGM, FITS, texto delimitado por tabuladores, y los formatos en bruto.

Plugins


La funcionalidad de “ImageJ” puede ampliarse mediante el uso de plugins escritos en Java. Los Plugins pueden añadir soporte para nuevos formatos de archivo o pueden filtrar o analizar imágenes. Los Plugins pueden instalarse en la carpeta situada en " plugins" dentro de ImageJ, dónde posteriormente se instalará de manera automática en el menú de plugins o que pueden ser instalados en otros menús mediante plugins / Teclas / instalar el plugin. Los Plugins pueden ser creados o modificados mediante plugins / Editar. Existen más de 150 plugins de ejemplo los cuales están disponibles para su descarga desde el sitio web ImageJ.

Look Up Tables (Tablas de Búsqueda)

http://rsbweb.nih.gov/ij/docs/images/fire.gif


Las imágenes en escala de grises se muestran usando una tabla de búsqueda de color que describe el color que se utilizará para cada uno de los 256 posibles valores de los píxeles muestra. Se pueden seleccionar paletas de color alternativos usando el submenú Image > LookUp Tables. Para cambiar dinámicamente los cambios realizados en las LUT se utiliza imagen > Ajuste > Brillo > Contraste. Y por otro lado, el submenú Analyze > Show LUT para mostrar la LUT de la imagen activa.
  1. Resultados

    1. Mean Shift


……

Bibliografía


[1] Comaniciu, Dorin; Meer, Peter. Mean Shift: A Robust Approach Toward Feature Space Analysis.

KDTree  http://www.cs.wlu.edu/~levy/software/kd/

ImageJ  http://rsbweb.nih.gov/ij/docs/concepts.html
1   2   3   4   5   6   7

similar:

Preliminares iconPreliminares

Preliminares icon1 algunos apuntes preliminares

Preliminares iconLos efectos de la globalización en el territorio de la Ciudad de...




Todos los derechos reservados. Copyright © 2019
contactos
b.se-todo.com